Rimfire Central Firearm Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter · #1 ·
Had a bit of a problem with my CZ 452 .17HMR the other day. After a couple of shots, I pulled the bolt back and it came straight out. I put it back in, and cycled the next round. Problem was, the bolt wouldn't cock, and thus no shot.

I worked the bolt quite a few times and couldn't get it to shoot. I couldn't see anything wrong, so I worked it a few more times, then all of a sudden it was back to working order.

Any ideas?
 

·
Premium Member
Joined
·
9,208 Posts
Probably a little piece of crud in the trigger group. If it was mine, I would take the stock off, and the mag well, then flush it out real good with some spray cleaner, blow it out with air and relube it. If you do this, I dont think you will have any more problem.
 

·
Registered
Joined
·
810 Posts
When i first purchased my HM2 the bolt wouldnt cock every 8-9 rounds. I would fire a shot and when i cycled another round and went to squeeze the trigger, nothing. Some said it could be the gunk lubricant inside. I took the bolt apart and cleaned it good. When i took it apart i didnt see the gunk i thought i would but since i put it back together i havent had any problems.
 

·
Registered
Joined
·
20 Posts
I had tha problem with the bolt coming out......... it was after I had taken the trigger return spring out...... in the quest of a lighter trigger pull :confused: I eventually got the Brookies kit. As jnyork said , it may may be just a bit of crud, but You could check the spring at the same time.
Paul
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top