Rimfire Central Firearm Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2,607 Posts
30R17

Mixed review here! I put a 3-9X40 Scopechief on it, bore-sighted it and went to the range. It didn't fire the first time I pulled the extremely heavy trigger! Had to hit every round twice to get them to fire! Only shot 5 rounds and sent it back to Savage. I like the looks of the gun, even with the scope, that's why I bought it though I actually intended it for my wife. The smith at the gunshop said the firing pin was too short! I also noticed that the bottom of each fired case was slightly bulged. Maybe Savage had a machining problem. They've had it for about 6 weeks now, I think!
 

·
Registered
Joined
·
2,607 Posts
30R17

Got the wife's 30R17 back from Savage today. They improved it by about 50%. That is, it shoots half the time now! The other half you still have to hit the round twice to get it to fire. Took it back to the gun shop again. The dealer suggested I try dealing directly with Savage myself. Gonna' try that tomorrow! We'll see! The saga continues!
 

·
Registered
Joined
·
2,607 Posts
30R17

Gonna' suggest that to them tomorrow. The dealer paid to have it shipped back to them the first time. I think they should simply replace the gun. I'll post the results of my phone call to them.
 

·
Registered
Joined
·
2,607 Posts
30R17

Called Savage this morning. Of course the nice young lady was nto about to commit to replacing the gun but they are paying to have it shipped back to them for "inspection" (did I say I just got this gun back from them?) and then they would call me. More to follow, I reckon!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top