Rimfire Central Firearm Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi, all:

My Classic (std. s/n 68xx) is pretty nice, only a few FTFs and stovepipes now and then - I use cheapo bulk ammo most of the time - BUT I do not like its trigger. Actually, I guess the trigger is a good one, in the sense that it has NO pretravel and is as crisp/predictable as can be. Those are excellent qualities. The pull is, however, harder than I'd like, but I never measured it for it is not "bad". Still, my main complaint is a behavior that can probably be cured by installing some sort of over-travel eliminator, but I'm not sure. This is one of the things that I'm hoping y'all can confirm for me.

If I shoot slowly and deliberately, and hold the trigger back as part of my "follow through", the trigger makes an annoying click sound (and feel) when I finally release it to its home position. Some part is obviously disengaging (or engaging) when the trigger moves from its rearward-most position to its foward-most position.

Please bear with me for a moment - I'm not an experienced "home-smith". I removed the trigger group from the receiver and tried to duplicate the behavior I am experienceing at the range. No problem doing so. Here's what I am seeing. Again, please be patient with me, as I am going to label the trigger-group parts in generic/layman's terms for I don't know (for sure) the proper names ... I'm hoping you can correct this!

OK ... Im holding the trigger group in my left hand, positioned as if the rifle's muzzle were pointing to my left. The hammer is "cocked" and the trigger is set to go. I push "down" on the hammer, pusing it to its rearward-most position. While holding it there, I pull the trigger all the way back and hold it there. As I am pulling the trigger back, I look down into the trigger group and see a part of the trigger group pivot forward. I believe this is the disconnector, but I'm not sure. (it is the rearward-most part of the trigger group, that seems to rest upon the pin that hold the safety's spring). For now, I will refer to this part as "disconnector". (please correct me if this is a "sear" or some other part!!!??)

AS I continue to hold the trigger back, I let-up on the hammer. The hammer does not return fully to its normal "cocked"/ready-to-fire position. Instead, It's engaging what I called the disconnector.
When I then slowly let-up on the trigger, the disconnector pivots rearward and releases its engagement with the "angle" on the hammer (secondary sear?). The hammer then snaps forward a tad with a loud CLICK and comes to rest in its "ready-to fire" position. (I'm guessing that the "primary sear" is now engaged)

OK, here come the questions:

1) So far, am I correct with my terminology?
2) Is this behavior normal for this gun?
3) Would an overtravel screw (or other mod. such as a shaved-down pencil eraser head glued to the trigger guard behind the trigger) correct this problem ... or at least what I'm calling a problem?

4) The tiny spring for the trigger seems to be the only thing that is giving me a hard trigger pull. I am think that this powerful little spring is forcing the disconnector too abruptly and causing it to "snap" rather violently. Might a softer spring both lighten the trigger pull and soften the transition from the disconnector to main sear?

THANX
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top