572 problems - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > >

Notices

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 01-14-2011, 01:41 PM
different
NRA Member - Click Here To Join!

Join Date: 
May 2002
Posts: 
548
TPC Rating: 
100% (11)
572 problems



Log in to see fewer ads
I just picked up a used remington 572 pump action and it has some sort of issue. Every once in awhile the pump mechanism seems to jam up before it cocks the rifle. It just seems to bind up on something before it's all the way back, and I can't bring it back any further. The only thing I can do is to slide it back foreward, and then try again. It only happens every once in awhile, but is very annoying. I haven't had a 572 in years so I don't remember, but when I roll the gun over I can hear something moving inside the action. is this normal? I don't want to take the gun apart and have pieces fly everything, but I thought maybe if I could clean it out inside (it's pretty dirty) then maybe that'd help. Are these easy to disassemble?

thanks
Reply With Quote
  #2  
Old 01-14-2011, 04:47 PM
Garandman

Join Date: 
Nov 2009
Posts: 
11
TPC Rating: 
0% (0)
I hope somebody can respond to this situation, because I have had the same experience. Took it to a smith and it worked fine for a while, but the problem came back. I have found that if you don't lock the tube follower in place, it will not jam. Of course it must be held muzzle end up to get it to feed. Regardless, not a pleasing situation. As an aside, mine has done this regardless of cleanliness.

So, I second the call for expertise on this topic!
Reply With Quote
  #3  
Old 01-14-2011, 04:48 PM
Garandman

Join Date: 
Nov 2009
Posts: 
11
TPC Rating: 
0% (0)
Forgot to add, they are easy to disassemble. Just drift the two pins holding in the trigger group.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 01-14-2011, 10:02 PM
boley's Avatar
boley
US Army Veteran NRA Member - Click Here To Join!

Join Date: 
Aug 2003
Location: 
Heart of Dixie
Posts: 
2,450
TPC Rating: 
100% (1)
different,I suggest pushing out the trigger plate pins (#85 & #86 on this schematic) and removing the trigger group to see what's rattling around inside the receiver.This level of disassembly isn't difficult.Please let us know what you find.
http://www.gunpartscorp.com/catalog/...spx?catid=4311

Garandman,I'm really guessing here.It sounds to me from your description that the force of the magazine spring is affecting proper feeding.Assuming that, it causes the carrier or it's spring to be suspect (#11 and #13).If the carrier is bent and dragging or it's spring weak it may not be able to overcome the magazine spring pressure.Not at all an expert on the model,I just like them.
Good luck to both of you at getting your 572's squared away.boley

Last edited by boley; 01-14-2011 at 10:09 PM.
Reply With Quote
  #5  
Old 01-18-2011, 12:06 PM
Garandman

Join Date: 
Nov 2009
Posts: 
11
TPC Rating: 
0% (0)
Boley,

thanks for the feedback. I will try this out.
Reply With Quote
  #6  
Old 01-18-2011, 02:49 PM
different
NRA Member - Click Here To Join!

Join Date: 
May 2002
Posts: 
548
TPC Rating: 
100% (11)
found the problem

I took apart my 572 and found the problem. There was a little piece of broken metal in there flopping around. I couldn't tell where it came from for the longest time. But it turns out that it is the little loop on the bottom of the disconnector. I can't see on the breakdown (thanks for the link boley) exactly what that little loop is for. Is there a spring that connects to there that I am also missing? I don't want to go ahead and order the disconnector and then find out I'm missing something else that I'll have to pay to ship again. Would anyone happen to know? also, the top end of the disconnector at gunparts is shaped different from mine. will that be an issue?

thanks everyone for the help. I sure appreciate it. I have been wanting one of these guns for years and this one was sold to me in good working condition and this is the way I received it and have not been too happy.
Reply With Quote
  #7  
Old 01-18-2011, 09:23 PM
boley's Avatar
boley
US Army Veteran NRA Member - Click Here To Join!

Join Date: 
Aug 2003
Location: 
Heart of Dixie
Posts: 
2,450
TPC Rating: 
100% (1)
http://www.brownells.com/.aspx/pid=1...t/DISCONNECTOR
I think the part thats broken off contacts the connector when the action bar lock is locked,aligning the connector with the sear. In other words it doesn't "attach" to anything,only contacts the connector.It looks to me that the single part (disconnector) will fix the rifle. Assuming that whatever caused the original part to break was a one time event resulting from improper assembly or such.Browells has a better price and it will be a new genuine Remington part.I usually get faster service and lower shipping rates from them as well.Good luck and I hope the one part does it.boley
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 01:07 AM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com
x