795 Firing Issue - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > > >

Notices

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 10-31-2019, 05:16 PM
AndraikX1996

Join Date: 
Oct 2019
Posts: 
4
TPC Rating: 
0% (0)
795 Firing Issue



Log in to see fewer ads
So I bought this rifle a little over three years ago. I never had any issue except the trigger guard breaking on me. However, now I've come across a pretty big issue when firing. It started by firing 5-6 rounds before it would poop out and not fire. Took it apart, cleaned it, put it back together. Soon after it would fire 1-2 rounds maybe 3 if I was lucky before doing the same thing. I took it out maybe 3 hours ago and tried to see if it was working properly after I did a major deep clean on it and it acts as if nothing is even in the chamber. No fire, no ding of the trigger working. I've taken apart and it seems that the firing pin is way too loose for what it should be.

I'm no expert on this rifle, but was curious what everyone else thought or had any ideas what it could be. Thanks in advance!
Reply With Quote
  #2  
Old 10-31-2019, 07:42 PM
MarlinBullseye
NRA Member - Click Here To Join!

Join Date: 
Apr 2005
Location: 
Lansing, Michigan
Posts: 
642
TPC Rating: 
0% (0)
I am not fully understanding your problem, when it fails, does the hammer fall? is firing pin trying to crush the rim of the cartridge?
Reply With Quote
  #3  
Old 10-31-2019, 08:13 PM
ferg
US Navy Disabled American Veteran NRA Member - Click Here To Join!

Join Date: 
Mar 2006
Location: 
SEOK
Posts: 
1,066
TPC Rating: 
100% (1)
1. Kinked main spring?

2. Loosen mounting screws and pull action assy as far forward in stock as possible, tighten screws.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 10-31-2019, 08:15 PM
Jammer22
NRA Member - Click Here To Join!

Join Date: 
Mar 2017
Location: 
Nowhere good
Posts: 
516
TPC Rating: 
0% (0)
Ammo type?
Reply With Quote
  #5  
Old 11-01-2019, 08:32 AM
AndraikX1996

Join Date: 
Oct 2019
Posts: 
4
TPC Rating: 
0% (0)
@MarlinBullseye, the pin isn't being hit at all. I took it all out of the rifle and "put it back together" to see if I could find out what's wrong. Even then, it looked like it wasn't moving the firing pin to where it needed to be. It would stick towards the back, until I leaned it forward and watched it slide its way to the front, where it would be if it were fully cocked and loaded.
Reply With Quote
  #6  
Old 11-01-2019, 08:33 AM
AndraikX1996

Join Date: 
Oct 2019
Posts: 
4
TPC Rating: 
0% (0)
@Ferg, I noticed it was slightly bent a while ago and was able to get it back to being straight. For your second idea, I'll definitely try that out!
Reply With Quote
  #7  
Old 11-01-2019, 08:34 AM
AndraikX1996

Join Date: 
Oct 2019
Posts: 
4
TPC Rating: 
0% (0)
@Jammer22, I've used nothing but CCI with it for as long as I've had it.
Reply With Quote
  #8  
Old 12-04-2019, 03:58 PM
Big Shrek's Avatar
Big Shrek
US Army Fire Fighter NRA Member - Click Here To Join!

Join Date: 
Feb 2009
Location: 
NW Florida
Posts: 
5,449
TPC Rating: 
0% (0)
Might have chipped the tip of the Firing Pin off.
Grab a new one from Marlin!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 07:13 AM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com
x