BuckMark slide locks back occasionally - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > > >

Notices

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 10-20-2021, 10:23 PM
ssv1761982

Join Date: 
Dec 2009
Posts: 
11
TPC Rating: 
0% (0)
BuckMark slide locks back occasionally



Log in to see fewer ads
I took out a new to me Buck Mark and the slide locks back occasionally. Just push the slide release and it continues like nothing is wrong.

This is my 1st Browning, where should I start looking for the problem? It is clean and appears to be barely used.

Thanks
Reply With Quote
  #2  
Old 10-20-2021, 10:49 PM
NWFRS

Join Date: 
Jun 2016
Posts: 
392
TPC Rating: 
0% (0)
Are you left-handed? Any chance you might be inadvertently pressing upward on that slide stop/release while firing? Do you have a second magazine to try?
Reply With Quote
  #3  
Old 10-20-2021, 11:31 PM
ssv1761982

Join Date: 
Dec 2009
Posts: 
11
TPC Rating: 
0% (0)
I am an old righty and only have the original mag. It fits my hand real nice but I will pay attention the next time I get it out. I don't think I am pressing up tho. I can just reach up and release it and keep on shooting.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 10-21-2021, 03:33 PM
JackM
Law Enforcement Officer NRA Member - Click Here To Join!

Join Date: 
Apr 2009
Location: 
SW Florida
Posts: 
114
TPC Rating: 
100% (1)
I've experienced the same thing and I'm right-handed. My right thumb would occasionally lift the slide lock mid-way through a magazine, though it wasn't obvious. I solved the problem by removing the "pad" portion of the lock leaving just enough extension to lock the slide back on the last shot. Then I simply use the "slingshot" method of releasing the slide to chamber the first round of a fresh magazine.
Reply With Quote
  #5  
Old 10-21-2021, 04:26 PM
Eric300's Avatar
Eric300
Law Enforcement Officer NRA Member - Click Here To Join!

Join Date: 
Mar 2007
Location: 
S/E lower Michigan
Posts: 
1,082
TPC Rating: 
100% (18)
Shooter induced 100%.
Reply With Quote
  #6  
Old 10-21-2021, 04:48 PM
GladesGuy's Avatar
GladesGuy
NRA Member - Click Here To Join!

Join Date: 
Mar 2013
Location: 
So. Fla.
Posts: 
4,088
TPC Rating: 
0% (0)
Clean it again. My Buck Mark lets me know it needs a good mineral spirits flush whenever the lock back starts becoming intermittant. I just remove the grips and dunk it in a tub of MS and let it sit overnight followed by oiling of the usual spots.
Reply With Quote
  #7  
Old 10-21-2021, 08:32 PM
ssv1761982

Join Date: 
Dec 2009
Posts: 
11
TPC Rating: 
0% (0)
I don’t see how my thumb could hit the lever so I will give it a good cleaning.

Thanks everybody.
Attached Images
File Type: jpg 992B846F-853C-4BDB-841F-945BF8D19160_1634862604159.jpg (367.6 KB, 5 views)
Reply With Quote
  #8  
Old 10-21-2021, 09:19 PM
Vacman369

Join Date: 
May 2021
Posts: 
13
TPC Rating: 
0% (0)
Since itís new to you, check that the slide stop spring is still there. You can feel it when you hold the slide back and move the slide stop up and down. Itís not a super strong spring but should return the stop to the down position when you push it up. If that spring is missing, the slide stop can work itís way up and lock the slide on you.

image.jpg

Good luck.
John
Reply With Quote
  #9  
Old 10-21-2021, 10:45 PM
remnar's Avatar
remnar
NRA Member - Click Here To Join!

Join Date: 
Dec 2008
Location: 
Washington
Posts: 
1,412
TPC Rating: 
0% (0)
Vacman might be on the right track. The spring can get very weak and it is possible for the slide-stop to "bounce" when the gun is fired. It is even more likely if the spring is missing.
Reply With Quote
  #10  
Old 10-22-2021, 06:59 PM
ssv1761982

Join Date: 
Dec 2009
Posts: 
11
TPC Rating: 
0% (0)
I didn't find anything obvious when I took it apart but I think it's fixed. The spring was functioning when I tested it before disassembly but it seems to be stronger now.
I think I am the 1st to open it up since 1989. I ran 10 rounds thru it without a glitch so time will tell. It had been hanging up about 2 out of every 10.

Thanks for the help!

(Usually I take anything I buy apart before even trying it out. This looked like new in the box so I skipped that step. )
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 06:05 AM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright ©2000-2018 RimfireCentral.com
x