Daisy Avanti 853 Received!!! - Page 2 - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > >

Notices

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #16  
Old 01-27-2011, 03:50 PM
toppkatt's Avatar
toppkatt is online now
NRA Member - Click Here To Join!

Join Date: 
Mar 2006
Posts: 
675
TPC Rating: 
100% (1)


Log in to see fewer ads
I, like many others here recommend the trigger work. It helped me immensely! I started with a heavy gritty trigger with lots of creep ( it felt like I was pulling two pieces of course sandpaper across each other and the creep felt like 3/16th of an inch. Try keeping it on target while pulling the trigger through that much gritty travel!) and some over travel. I ended up with smooth as glass pull, almost no creep and less over travel.
Good luck. I like what you did with the sights, but I installed a scope since I was only one of about 3 people in my air gun league that was shooting open sights. Just didn't seem 'fair'.
Reply With Quote
  #17  
Old 02-11-2011, 01:41 AM
Dr. Internet
US Navy Veteran NRA Member - Click Here To Join!

Join Date: 
Feb 2011
Location: 
San Antonio, TX
Posts: 
221
TPC Rating: 
0% (0)
Charlotte,
I also have a 753 and put a 4x scope on it, too. However, I could never get the scope adjusted to shoot high enough (barrel droop?). I tried several different scopes. Someone suggested that I get some height adjustable scope rings. Did you have a similar problem?
Reply With Quote
  #18  
Old 02-11-2011, 07:16 PM
Charlotte's Avatar
Charlotte
US Air Force Veteran NRA Member - Click Here To Join!

Join Date: 
Sep 2004
Location: 
Atlanta
Posts: 
1,559
TPC Rating: 
0% (-1)
As a matter of fact I now have the cheapest of all possible scopes on my 753. I am using a Tasco 3-7X20 that cost about $15-20 new and it is just fine. Not the greatest or brightest but for what I'm doing in my basement it is just fine.
I didn't have any problems with the 4X scope, I just wanted to lower the line of sight with the smaller scope. This cheap little Tasco is not giving me any problems and I may try it on one of my CZ's.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 02:57 AM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com
x