My Savage MKII GL Cured Itself! - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > >

Notices

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 10-12-2019, 03:57 PM
Fiddleharp

Join Date: 
Dec 2007
Location: 
Crackerville, Florida
Posts: 
518
TPC Rating: 
0% (0)
My Savage MKII GL Cured Itself!



Log in to see fewer ads
Some of you longtime members might remember a series of posts by yours truly bitterly complaining of the constant failure to extract issues with my left-handed Savage. Back in 2012, I found it at a local shop and when told that is was used, was quite surprised. If he told me it was new, I would have believed him. It must have been some kind of safe queen. Not one sign of normal wear anywhere.
Unfortunately, it didn't take me long to fall out of love with it. It immediately showed it was unreliable by failing to extract fired rounds just when I needed it most, like when a large coon fell from a tree in my backyard, and somehow blamed me for his misfortune!
While he stood there, growling at me, I took that opportunity to rack home another round. Unfortunately, my rifle had other ideas, and I ended up beating a hasty retreat back into the house. I don't know whatever became of that raccoon.
Anyway, this problem went on for years while I tried one remedy after another, most suggested by people on this forum. Nothing worked.
I never bothered getting rid of this rifle because it was the first left-handed .22 bolt rifle I'd ever seen in my life, and I knew I'd never see another left-handed .22 bolt rifle for the rest of my life. Besides, this thing is dead-nuts accurate.
Anyway, for varmint control and hunting, I counted on my good old Marlin 39A, and let this Savage become just an occasional target and plinking rifle.
As the years went by, it slowly occurred to me that the Savage was experiencing less and less failures to extract the more I shot it.
Now, much to my surprise, I experience NO FTE's whether I clean the chamber or not! This rifle has become 100% reliable!
How did this happen? Was the gun "broken in" or "shot in?"
I'm using the same squirrel-control CCI Quiets that I've been using since Day One.
How can a mechanical thing simply fix itself?
Just wondering. Not complaining!
Reply With Quote
  #2  
Old 10-12-2019, 04:11 PM
Basrem

Join Date: 
Mar 2011
Posts: 
1,007
TPC Rating: 
0% (0)
Just wore the right way

Sent from my LM-X410.FGN using Tapatalk
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 12:12 PM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com
x