Two ruger to the range, need help with diagnosing issues. - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > >

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 09-21-2017, 11:54 PM
chomorro

Join Date: 
Jul 2017
Posts: 
108
TPC Rating: 
0% (0)
Two ruger to the range, need help with diagnosing issues.



Log in to see fewer ads
Just came back from the range. Have an old ruger in a p90 stock. Just put in a jwh competition bolt in the and ran 100 rounds through it. Had about 6 of these halfway loading problems. I'm using the high velocity spring for the bolt, think I should go standard or light spring? See pic.

The other ruger was in Stock formation with a scope. Ran 100 rounds and had about 3 failures to load, all in the same mag so I'm blaming the mag. The main issue is about 6 failures to fire (I think) the bullet was stuck in the barrel and had to be pried out. Strange thing was there was no firing pin indent on them. Ideas?

Thanks you for the help! All bulk ammo 1280 fps golden bullet.



Sent from my SM-N910V using Tapatalk
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 03:41 PM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com
x