Fail to eject with Polymer mag - DIY time? - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > >

Join Team RFC to remove these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-03-2012, 06:19 PM
Domaca's Avatar
Domaca
NRA Member - Click Here To Join!

Join Date: 
Apr 2012
Location: 
Ireland
Posts: 
11
TPC Rating: 
0% (0)
Fail to eject with Polymer mag - DIY time?



Log in to see fewer ads
Hello again,

The constant rain here has me looking for problems to solve. Today it's my 10 round polymer mags, which plague my shooting with their consistent failure to eject. I searched the threads here and did some googling, but without getting an answer.

I have one 5 round steel magazine which is just a pleasure to use. I can cycle the bolt as slowly as I wish and it still feeds and ejects smoothly. So this is my standard.

I also have three polymer 10 round magazines. They feed without fail, but ejection is a constant source of pain. If I cycle slowly, or even just moderately fast (what I consider a "normal" strength cycle), it WILL fail to eject. 100% of the time.



If I cycle fast and furious, and I do mean with considerable force and vigour, then the odds of a failure to eject are reduced. I just tried it there (without firing) and 4 rounds did not eject out of 10. And that's with a very strong and fast yanking back of the bolt. This does not meet my standard Though I see from other threads on RFC that nearly everyone is completely satisfied with their polymer mag.

Now, my rifle is a 1991 CZ Mod 2-E-S, which I believe to be basically a 452. The mags I bought were these: http://www.budsgunshop.com/catalog/p...POLY+22LR+10RD
(The product picture looks nothing like the magazine)

Here is a very poor and out of focus photo I just took of the metal and plastic mags, aligned by the rear-side "shelf".



There is a noticeable difference in the height of the top round, along with the height of the rear guides of the magazine.

Is there anyone here with the same problem, and did you find a solution?

Can anyone recommend a course of action to improve matters?

I am of the opinion that if I were to shave the top of the plastic mag it may improve the situation, as I think the cartridge rim just isn't hitting the little ejector bump inside the chamber. (I don't know the correct terminology!). If this is the case, then how come a rigorous cycling works sometimes? Anyway, a shaving may well weaken the magazine, so that the pressure of a full mag could break the thinner plastic at the top, leaving the mag totally useless. Thoughts??

I hope I was understandable throughout all that. Thanks for your help, guys!
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 03:07 PM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com
x