Reports of problems - Page 2 - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > >

Notices

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #16  
Old 10-02-2019, 03:13 PM
gobigkahuna
US Navy Veteran Fire Fighter

Join Date: 
Mar 2019
Location: 
North Carolina
Posts: 
11
TPC Rating: 
0% (0)


Log in to see fewer ads
I've had mine for about a month. I've put maybe 500 or 600 rounds through it so far. I initially had an issue with one of the magazines, but a friend figured out what was wrong. The follower was installed incorrectly (probably done at the gun shop and not Ruger). It now shoots 100% with its favorite ammo (CCI mini mag and Remmington golden bullets), and only a rare FTF or FTE if I use something else. I'm happy.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 07:12 AM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com
x