Tikka T1X. Ejection problem - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > >

Notices

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 01-08-2019, 09:59 PM
Jrobert

Join Date: 
Jan 2019
Posts: 
6
TPC Rating: 
0% (0)
Tikka T1X. Ejection problem



Log in to see fewer ads
So I picked up a new T1x, first time out the the range it looks extreamly promising. However I seam to be having an ejection problem. Have shooting center x, sk rifle match and CCI Standard Velocity. Rifle feeds from the mage just fine and will extract the empty from tbe chamber with now problem but drops about 40% of the spent casses back into the action. Extractor problem? Ejector problem? Im not sure I want to start reprofiling the ejector without good availability for a replacement if I mess it up. Any suggestions?
Reply With Quote
  #2  
Old 01-09-2019, 05:24 AM
ForgivenFlyer

Join Date: 
Apr 2018
Posts: 
32
TPC Rating: 
0% (0)
Does changing the speed you operate the bolt make any difference?

Can you try to look through the ejection port and see how the case behaves when you slowly pull the bolt backwards? You could maybe based on that make a fast assumption whether it is the ejection nail having not enough grip or the ejector "spring" (located on the left side of the bolt in the action) not doing its job.
Reply With Quote
  #3  
Old 01-09-2019, 09:44 AM
MarkS
NRA Member - Click Here To Join!

Join Date: 
Jul 2015
Location: 
SW VA
Posts: 
302
TPC Rating: 
0% (0)
I had the same thing going on with mine. I thought I needed to pull faster. That did not work, it dropped more. I found that a slow pull worked, it would edject fine.

Mark
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 01-09-2019, 11:24 AM
Noknot

Join Date: 
Mar 2018
Posts: 
295
TPC Rating: 
0% (0)
This is really not what a person wants to hear. I have read where more and more people are complaining about jamming and extraction issues. We wait for almost a year, being told that Tikka wants to make sure that everything is worked out before they start shipping and now so many people having the same problem.
Reply With Quote
  #5  
Old 01-09-2019, 03:06 PM
kisssofdeath's Avatar
kisssofdeath
NRA Member - Click Here To Join!

Join Date: 
Dec 2012
Location: 
Greer, SC
Posts: 
1,917
TPC Rating: 
0% (0)
First off, I don't have the Tikka T1X. I had problems with my Zephyr II ejecting so anything can happen to any gun. The problem is you have a 1,000 people who buy "X" gun. Out if those 975 are totally happy with the performance but only a few tell it. On the other side you have 25 who have various issues with their gun and they tell the world and the world accepts this as fact that almost everyone who buys "X" gun is having issues.

When I did work, and when I received calls from customers, none called to tell me what a fine job I was doing.
Reply With Quote
  #6  
Old 01-09-2019, 04:30 PM
62Ranger13
US Air Force Veteran NRA Member - Click Here To Join!

Join Date: 
Feb 2018
Posts: 
315
TPC Rating: 
0% (0)
Quote:
Originally Posted by kisssofdeath View Post
First off, I don't have the Tikka T1X. I had problems with my Zephyr II ejecting so anything can happen to any gun. The problem is you have a 1,000 people who buy "X" gun. Out if those 975 are totally happy with the performance but only a few tell it. On the other side you have 25 who have various issues with their gun and they tell the world and the world accepts this as fact that almost everyone who buys "X" gun is having issues.

When I did work, and when I received calls from customers, none called to tell me what a fine job I was doing.
I was trying to find a way to say that. You have an excellent point.
This should be shared in the "disappointment" thread.

Last edited by 62Ranger13; 01-09-2019 at 04:33 PM.
Reply With Quote
  #7  
Old 01-09-2019, 05:12 PM
juleslewis

Join Date: 
Aug 2008
Posts: 
28
TPC Rating: 
100% (1)
I've run about 300 rounds through mine with no problem. Accuracy is comparable to my Anschutz 54's.
Reply With Quote
  #8  
Old 01-09-2019, 05:41 PM
Noknot

Join Date: 
Mar 2018
Posts: 
295
TPC Rating: 
0% (0)
62Ranger13, its been awhile, didnt you pre-order from Whittakers. If so have you gotten yours yet?
Reply With Quote
  #9  
Old 01-09-2019, 06:21 PM
Jrobert

Join Date: 
Jan 2019
Posts: 
6
TPC Rating: 
0% (0)
Yep not here to bash the t1x fellas, spent 500 on the rifle and another 700 on the chassis and feed it premium ammo. Thing shoots a fuz under half at 50 and fuz under 1” at hundred( all with factory stock and 50mm scope, hard to get a good cheak weld. Haven’t shot it yet in the xlr chassis yet but I have a feeling it will tighten up a bit with the added comferts of a better platform. Had and still may have every intention of swapping the barrel out of it didn’t/dosnt preform. (More than happy with it as is). So that said I think the entire setup is solid and willing to invest some cash in it. Just asking for some advice on getting it to eject. A friend of mine has one shooting side by side it shoots even better than mine. Two rifles shooting sub minut of angle, we got board shooting the last link on a pice of chain hanging at 200yd the other day. Difference in the two rifles is his throws the empties clear of the port and mine dose not. I’m not sending it back to the factory for any reason so need advice on fixing it. Thanks.
Reply With Quote
  #10  
Old 01-09-2019, 06:33 PM
kisssofdeath's Avatar
kisssofdeath
NRA Member - Click Here To Join!

Join Date: 
Dec 2012
Location: 
Greer, SC
Posts: 
1,917
TPC Rating: 
0% (0)
jrobert, you will love that XLR chassis.
Reply With Quote
  #11  
Old 01-09-2019, 06:48 PM
kisssofdeath's Avatar
kisssofdeath
NRA Member - Click Here To Join!

Join Date: 
Dec 2012
Location: 
Greer, SC
Posts: 
1,917
TPC Rating: 
0% (0)
Quote:
Originally Posted by 62Ranger13 View Post
I was trying to find a way to say that. You have an excellent point.
This should be shared in the "disappointment" thread.
Yeah, unfortunately what I said applies to many things in life. Seems like it's human nature to be antagonistic about everything.
Reply With Quote
  #12  
Old 01-09-2019, 06:53 PM
Noknot

Join Date: 
Mar 2018
Posts: 
295
TPC Rating: 
0% (0)
Quote:
Originally Posted by Jrobert View Post
Yep not here to bash the t1x fellas, spent 500 on the rifle and another 700 on the chassis and feed it premium ammo. Thing shoots a fuz under half at 50 and fuz under 1” at hundred( all with factory stock and 50mm scope, hard to get a good cheak weld. Haven’t shot it yet in the xlr chassis yet but I have a feeling it will tighten up a bit with the added comferts of a better platform. Had and still may have every intention of swapping the barrel out of it didn’t/dosnt preform. (More than happy with it as is). So that said I think the entire setup is solid and willing to invest some cash in it. Just asking for some advice on getting it to eject. A friend of mine has one shooting side by side it shoots even better than mine. Two rifles shooting sub minut of angle, we got board shooting the last link on a pice of chain hanging at 200yd the other day. Difference in the two rifles is his throws the empties clear of the port and mine dose not. I’m not sending it back to the factory for any reason so need advice on fixing it. Thanks.
Have you tried just contacting Beretta and see what they say?
Reply With Quote
  #13  
Old 01-09-2019, 07:02 PM
Jrobert

Join Date: 
Jan 2019
Posts: 
6
TPC Rating: 
0% (0)
I have not, That would be way to easy. I will contact them. I would think that they will tell me to send it in but then again they may have some advice.
Reply With Quote
  #14  
Old 01-09-2019, 07:05 PM
62Ranger13
US Air Force Veteran NRA Member - Click Here To Join!

Join Date: 
Feb 2018
Posts: 
315
TPC Rating: 
0% (0)
Quote:
Originally Posted by Noknot View Post
62Ranger13, its been awhile, didnt you pre-order from Whittakers. If so have you gotten yours yet?
Yes, I did have an order with Whitakers. A T1 became available here in MO so I bought it instead. I paid a little extra (499.00) over Whitakker's price and then had to pay state tax and a transfer fee on top of that. I am very happy with the rifle. It's a bummer that you are still waiting on one.
Reply With Quote
  #15  
Old 01-09-2019, 07:20 PM
fwood
US Navy Veteran

Join Date: 
Feb 2012
Location: 
In the Middle of Texas
Posts: 
548
TPC Rating: 
0% (0)
You might send a note to lithgow_101. I think he had some issues out of the box similar to yours. I thought it was the extractor edge but it was a quick fix. Maybe just a little dressing.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 10:35 PM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com
x