First round in mag issue - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > >

Notices

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 04-10-2018, 10:17 AM
DTDK's Avatar
DTDK
NRA Member - Click Here To Join!

Join Date: 
Feb 2009
Posts: 
751
TPC Rating: 
100% (8)
First round in mag issue



Log in to see fewer ads
The first round always nose dives into the top of the chamber and will not feed. If I only load 9 in a mag then I rarely have an issue. I am using mec gar mags so there should not be a problem.

Any one have a suggestion as to what may be the culprit?
Reply With Quote
  #2  
Old 04-10-2018, 11:00 PM
Mklluser
NRA Member - Click Here To Join!

Join Date: 
Mar 2016
Location: 
NC mountains
Posts: 
97
TPC Rating: 
0% (0)
1st round issues

Personally, I have had poor results from Mec-Gar mags. Try 1 Original Ruger mag just for reference. Or just load 9 and be happy. I know of no quick fix. Maybe someone with more experience will respond. Good luck!
Reply With Quote
  #3  
Old 04-11-2018, 11:11 AM
Test_Engineer

Join Date: 
Nov 2014
Location: 
On a Colorado glacier
Posts: 
1,909
TPC Rating: 
0% (0)
Could be the mags, or it could be the release.

If you push the button down by hand, do you feel a sudden increase in resistance as you get close to the bottom (between position 9 and 10)? If so, the spring is binding up.

It could be pinching on the plunger. Sanding and polishing the plunger would be the cure for this. It could also be getting squished between the shell and the follower. Sanding a little off the back of the follower would give the spring more room. Or clipping a couple coils off the spring would make it spread a little less and not bind with the room it already has.

As suggested, try a Ruger mag and see if the same problem exists. If it does, the release may need some tuning.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 04-11-2018, 05:26 PM
Mklluser
NRA Member - Click Here To Join!

Join Date: 
Mar 2016
Location: 
NC mountains
Posts: 
97
TPC Rating: 
0% (0)
1st round issues

DTDK, I also recommend that you do not depress the slide release button to load 1st round . Factory says to slingshot slide to bring 1st round to battery. I made this mistake for 10 years with no problems till someone on this websight reminded to read the manual. It's there. Hope this will help.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off




All times are GMT -5. The time now is 05:52 PM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com
x