I Messed Up! - RimfireCentral.com Forums

Go Back   RimfireCentral.com Forums > >

Join Team RFC to remove these ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 03-24-2019, 07:22 PM
flynt

Join Date: 
Apr 2006
Posts: 
37
TPC Rating: 
0% (0)
I Messed Up!



Log in to see fewer ads
I picked up a slightly used Mark III a couple of years ago. Disassembled and cleaned her a couple of times. I tried it again, last week and somehow really screwed the pooch this time.

I disassembled the bolt for the first time, and appear to have put it back together OK. Reattached upper, inserted bolt. Had problems getting the MS housing to latch up and close fully. Inserted mag, pulled trigger and pushed hammer forward. Then, oops! MS housing latches 100%. Bolt closes 100%, but gun does not appear to dry fire. Mag gets stuck & I have to pry it out. I can no longer disassemble her. The MS housing will only swing open about 10%. The bolt release button doesn’t seem to be engaged. Help! Thanks!


Sent from my iPhone using Tapatalk

Last edited by flynt; 03-24-2019 at 07:37 PM.
Reply With Quote
  #2  
Old 03-24-2019, 08:30 PM
Bradical
NRA Member - Click Here To Join!

Join Date: 
May 2013
Location: 
Southeast Pennsylvania
Posts: 
1,215
TPC Rating: 
0% (0)
Sounds like you have the hammer in the wrong position. Check manual break down procedure. With the muzzle pointed in correct direction, bang side of firearm with your hand so as to jostle the hammer into the correct position. Sometimes, a plastic mallet does the trick. Proceed with disassembly.

Hope this does the trick.
Reply With Quote
  #3  
Old 03-25-2019, 09:55 AM
valvestem's Avatar
valvestem
US Coast Guard Veteran Law Enforcement Officer NRA Member - Click Here To Join!

Join Date: 
Apr 2016
Location: 
Maine
Posts: 
169
TPC Rating: 
0% (0)
If the MSH only comes out a dite, I think thats because you need to put in a mag, point muzzle down, pull trigger and hold it, and tap back of bolt with a rubber/plastic/wood hammer to make the hammer drop into the "fired" position-straight up.
Reply With Quote
 
  #4  
Old 03-25-2019, 08:27 PM
FredVK
US Navy Veteran

Join Date: 
Nov 2015
Posts: 
218
TPC Rating: 
0% (0)
As others have noted, hammer needs to be moved into the proper position. This......

https://www.youtube.com/watch?v=uWxtnC8amO4

Last edited by FredVK; 03-25-2019 at 08:31 PM.
Reply With Quote
  #5  
Old 03-26-2019, 03:23 PM
flynt

Join Date: 
Apr 2006
Posts: 
37
TPC Rating: 
0% (0)
Thanks, everybody!

Still won't budge. May end up at my trusty gunsmith's.
Reply With Quote
  #6  
Old 03-26-2019, 05:26 PM
LostLensCap

Join Date: 
Mar 2015
Location: 
Barrackville WV
Posts: 
7
TPC Rating: 
0% (0)
Try this

https://www.youtube.com/watch?v=k7nDefvB1Io
Reply With Quote
  #7  
Old 03-26-2019, 06:24 PM
whtsmoke's Avatar
whtsmoke
US Army Veteran NRA Member - Click Here To Join!

Join Date: 
Aug 2006
Location: 
Kearney Missouri
Posts: 
250
TPC Rating: 
0% (0)
Send a message via Yahoo to whtsmoke
Mk lll fieldstrip

Watched your video and it looks easier than I have made myself think its hard to do, I have never field stripped mine just clean and blow with the compressor. I am going to give this a try.
Reply With Quote
  #8  
Old 03-26-2019, 07:39 PM
Bradical
NRA Member - Click Here To Join!

Join Date: 
May 2013
Location: 
Southeast Pennsylvania
Posts: 
1,215
TPC Rating: 
0% (0)
Quote:
Originally Posted by LostLensCap View Post
Yup! This video nails the reassembly steps by:

1) Pre-setting the hammer in the correct hammer down (fired) position
2) Pre-installation of the bolt in the barrel assembly, which allows reassembly with hammer in the fired position
3) Locking the barrel and grip frame together, with hammer in correct orientation
4) And, finally, confirming the hammer strut is properly engaging with the mainspring

Thanks for posting.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I think I messed up w5i2n Winchester 52 9 12-18-2018 07:09 AM
My Model 1914 is messed up! Help! grapppa Savage/Stevens 16 02-22-2018 04:40 PM
Well Photobucket bucket just messed things up FFournier CZ / Brno 76 07-07-2017 10:39 PM
I seem to have messed up my 10/22 in reassembly ItsKYRO Anything 10/22 41 01-15-2017 11:10 AM
Messed up my gun leavinc CZ / Brno 80 12-08-2016 07:43 AM



All times are GMT -5. The time now is 02:10 PM.

Privacy Policy

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright ©2000-2018 RimfireCentral.com
x