RimfireCentral.com Forums

RimfireCentral.com Forums (https://www.rimfirecentral.com/forums/index.php)
-   Tippmann Arms (https://www.rimfirecentral.com/forums/forumdisplay.php?f=485)
-   -   trigger did not reset (https://www.rimfirecentral.com/forums/showthread.php?t=1223649)

mostly22lately 05-18-2021 03:13 PM

trigger did not reset
 
M4-22 Elite rifle. After the first 75 rounds on a new rifle, the trigger began not resetting after firing.

Couldn't figure it out, at first, then I 'solved' the problem by manually 'pulling' the trigger back with my finger. It was binding somehow.

Brought it home, careful cleaning and re-lube, lots of manually working the whole mechanism, seems like it'll be fine but of course this can be found out only at the range. Gotta get back there.

--> Anyone else have a similar experience?

Other than this probably teething-pain type event, I am delighted so far.

J12johnson 11-09-2021 09:57 AM

Not sure if you figured this out or not. I recently had the same issue on an elite pistol I just bought. I think they had the trigger spring in backwards. I turned it around and haven’t had any more issues with the trigger reset.

Quote:

Originally Posted by mostly22lately (Post 12320339)
M4-22 Elite rifle. After the first 75 rounds on a new rifle, the trigger began not resetting after firing.

Couldn't figure it out, at first, then I 'solved' the problem by manually 'pulling' the trigger back with my finger. It was binding somehow.



Brought it home, careful cleaning and re-lube, lots of manually working the whole mechanism, seems like it'll be fine but of course this can be found out only at the range. Gotta get back there.

--> Anyone else have a similar experience?

Other than this probably teething-pain type event, I am delighted so far.


KiddsTippmann 01-01-2022 07:31 AM

Any follow up on what the issue was?

My trigger pin walked, and caused a non reset malfunstion.

mostly22lately 01-01-2022 03:26 PM

Quote:

Originally Posted by KiddsTippmann (Post 12575911)
Any follow up on what the issue was?

My trigger pin walked, and caused a non reset malfunction.

Mine just needed a bit of polishing, it turned out, but I ended up getting a different drop in trigger (other threads cover this topic) anyway.

Had mine out yesterday for this first time in a long while. You're right, you can go through the ammo with the Tippmann, 45 rounds of 'testing' happened in what seemed like a few moments.

Running with Federal Automatch from Walmart at 6 cents a round. Unfortunately this ammo is notorious lately for 2-5% FTFs. On the other hand, it is clean and groups well.

Please post what anti walk pins you end up getting and how you like them.

KiddsTippmann 01-05-2022 07:20 PM

Quote:

Originally Posted by mostly22lately (Post 12576609)
Mine just needed a bit of polishing, it turned out, but I ended up getting a different drop in trigger (other threads cover this topic) anyway.

Had mine out yesterday for this first time in a long while. You're right, you can go through the ammo with the Tippmann, 45 rounds of 'testing' happened in what seemed like a few moments.

Running with Federal Automatch from Walmart at 6 cents a round. Unfortunately this ammo is notorious lately for 2-5% FTFs. On the other hand, it is clean and groups well.

Please post what anti walk pins you end up getting and how you like them.

Thanks for the info.
I ordered the Strike Industries anti-walk pin kit. I will update with fitment.

KiddsTippmann 01-08-2022 06:23 PM

1 Attachment(s)
Strike Industries anti-walk pins fit just fine.

soshuman 01-17-2022 01:16 AM

Please help. I am having this issue with my new M4-22. It started right from new, when I was trying to find what ammo it likes best for accuracy. At the time I didn't think much about it, because I thought it could have just been different brands. Also, I thought it could have been the factory trigger, which I was going to swap out anyway. Now trigger group installed and hit a competition today. After about 20 rounds, it practically became a bolt action (every 2-3 rounds I had to charge it manually). Between strings I would oil the bolt up real good and that would get me another 20-30 rounds before it was back to messing up again. Any ideas?

TippMann007 01-17-2022 11:35 AM

Quote:

Originally Posted by soshuman (Post 12594715)
Please help. I am having this issue with my new M4-22. It started right from new, when I was trying to find what ammo it likes best for accuracy. At the time I didn't think much about it, because I thought it could have just been different brands. Also, I thought it could have been the factory trigger, which I was going to swap out anyway. Now trigger group installed and hit a competition today. After about 20 rounds, it practically became a bolt action (every 2-3 rounds I had to charge it manually). Between strings I would oil the bolt up real good and that would get me another 20-30 rounds before it was back to messing up again. Any ideas?

Since it's new..
You should call Tippmann Arms and send it in for repair before it gets worse

soshuman 01-17-2022 10:05 PM

Tippmann007, That is the plan, as soon as I get it back to house. I'm still out of state at the event. I thought I would pop on and see if there were any known easy fixes.


All times are GMT -5. The time now is 04:28 PM.

DMCA Notice

Powered by vBulletin
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Search Engine Optimisation provided by DragonByte SEO (Lite) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
Copyright 2000-2018 RimfireCentral.com